Flash Player fix for Mac PPC

Flash Player fix for Mac PPC

USE IT AT YOUR OWN RISK! THIS IS NOT AN OFFICIAL RELEASE. THERE ARE NO GUARANTEES OR WARRANTIES. Im not claiming ownership or anything else, I just “twicked” it a bit to make it work. Because APPLE and ADOBE don’t give a sh1t about PPC anymore. Here is the last available version of Flash Player plug-in for PCC Macs that will let you view embedded YouTube videos in Facebook. Currently if you are on a PPC Mac and you click on videos in Facebook and some videos on CNN and some other sites, it will tell you to update to the new Flash Player… THERE IS NO NEW FLASH PLAYER FOR PPC MACs. PPC architecture is officially no longer supported by APPLE or ADOBE. Download to your desktop, unzip it, and read the instructions… I tried to be a clear as possible. DOWNLOAD HERE… www.steelbin.com Just knowing that i helped a fellow Mac user is reward enough… But If this made your life a bit less frustrating, or if you think I’m cute… he he he… ; ) … you can send a few (thousand) bucks for coffee via PayPal: steelbin@gmail.com
Video Rating: 4 / 5

20 Replies to “Flash Player fix for Mac PPC”

  1. Thanks for all your helpful work & sharing What about the early 2 GB intel´╗┐ 10.5.8 – I have the same problem as the PPC – can’t install the recommended flash Adobe Flash Player version 10.3.183.17 update Cheers, Seb

  2. Hats off to you! You have done a great service for all of us PPC holdouts. On my PowerMac G4 Dual 1.25´╗┐ GHz I can still edit movies, etc–but was blocked from watching newer flash content on the web until coming across your elegant modification of the Flash plugin. Removing the 10.6 bloat too was the icing on the cake. BTW, your plugin also works great in Firefox 3.6. Thanks so much!

  3. Wow… you’re a genius mate.. thanks a million for this excellent bit of software… ­čÖé It was bad enough that Facebook ditched support for PPC Macs amongst others but just this week I got really peed off when the BBC suddenly dropped support too for their online channels… Now thanks to you I can again watch video online using my old PPC G5 iMacs running OSX 10.5.8 and don’t have to go out and buy a poxy intel´╗┐ iMac… ­čÖé Thanks once again for this… ­čÖé

  4. when it’s a osx10.5.8, even it’s Intel, u do need something to solve the flash problem, as the flash 11 is no more support the osx10.5, the most i can get is flash 10.3 and i did face problems when loading some new´╗┐ flash products. of coz there’s another way to solve it out, like, upgrade the os to 10.6, but it’s just not my choice as the machine is for running some old programs. anyway, this plug-in seems work for old ver intel mac at this moment, thx!

  5. You many need to grant permission to the flash plugin to use your camera. You can access the flash plugin prefs by right clicking on a flash item in´╗┐ the window. Cheers!

Leave a Reply